Vous êtes ici : Accueil / Forums & ML / Forum Zope / Forum Général Zope / AttributeError: @@plone

AttributeError: @@plone

Remonter à Forum Général Zope
  • AttributeError: @@plone

    Envoyé par fcarlier le 2 Octobre 2006 à 09:45
    Bonjour,

    J'ai régulièrement cette erreur sur mon site, avec n'importe qu'elle type d'url.
    Le user fait un back du navigateur, puis recommence et cela marche !!! bizarre.

    Je n'arrive pas à isoler le probleme:
    Zope 2.9.3
    Plone 2.5
    Python 2.4.3

    J'ai mis dans le répertoire Products de mon instance Five 1.3.7 pensant que le probleme
    venait du Five 1.3.5 de Zope. mais pas de changement.

    Vous auriez des pistes car cela pourrit l'ambiance des users sur l'usage du site !!!!

    Merci d'avance

    Voici le traceback :

    Traceback (innermost last):
    Module ZPublisher.Publish, line 115, in publish
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Products.CMFFormController.FSControllerPageTemplate, line 96, in __call__
    Module Products.CMFFormController.BaseControllerPageTemplate, line 39, in _call
    Module Products.CMFFormController.ControllerBase, line 243, in getNext
    Module Products.CMFFormController.Actions.TraverseTo, line 36, in __call__
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Products.CMFFormController.FSControllerPythonScript, line 109, in __call__
    Module Products.CMFFormController.ControllerBase, line 243, in getNext
    Module Products.CMFFormController.Actions.TraverseTo, line 36, in __call__
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Products.CMFFormController.FSControllerPythonScript, line 109, in __call__
    Module Products.CMFFormController.ControllerBase, line 243, in getNext
    Module Products.CMFFormController.Actions.TraverseTo, line 36, in __call__
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Shared.DC.Scripts.Bindings, line 311, in __call__
    Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    Module Products.PageTemplates.ZopePageTemplate, line 256, in _exec
    Module Products.PageTemplates.PageTemplate, line 104, in pt_render
    - <ZopePageTemplate at /E2_G2006/login_success>
    Module TAL.TALInterpreter, line 238, in __call__
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 749, in do_useMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 457, in do_optTag_tal
    Module TAL.TALInterpreter, line 442, in do_optTag
    Module TAL.TALInterpreter, line 437, in no_tag
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 749, in do_useMacro
    Module TAL.TALInterpreter, line 281, in interpret
    Module TAL.TALInterpreter, line 511, in do_setGlobal_tal
    Module Products.PageTemplates.TALES, line 221, in evaluate
    - URL: file:CMFPlone/skins/plone_templates/global_defines.pt
    - Line 3, Column 0
    - Expression: standard:'context/@@plone'
    - Names:
    {'container': <PloneSite at /E2_G2006>,
    'context': <PloneSite at /E2_G2006>,
    'default': <Products.PageTemplates.TALES.Default instance at 0xb720388c>,
    'here': <PloneSite at /E2_G2006>,
    'loop': <Products.PageTemplates.TALES.SafeMapping object at 0xb0f1d78c>,
    'modules': <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter instance at 0xb71a748c>,
    'nothing': None,
    'options': {'args': ()},
    'repeat': <Products.PageTemplates.TALES.SafeMapping object at 0xb0f1d78c>,
    'request': <HTTPRequest, URL=http://..../login_form>,
    'root': <Application at >,
    'template': <ZopePageTemplate at /E2_G2006/login_success>,
    'traverse_subpath': [],
    'user': <PloneUser 'auchaudet'>}
    Module Products.PageTemplates.Expressions, line 185, in __call__
    Module Products.PageTemplates.Expressions, line 173, in _eval
    Module Products.PageTemplates.Expressions, line 127, in _eval
    - __traceback_info__: context
    Module Products.PageTemplates.Expressions, line 286, in restrictedTraverse
    - __traceback_info__: {'path': ['@@plone'], 'TraversalRequestNameStack': []}
    Module Products.Five.traversable, line 126, in __bobo_traverse__
    AttributeError: @@plone
  • Re: AttributeError: @@plone

    Envoyé par fcarlier le 4 Octobre 2006 à 07:34
    Personne n'est inspiré ?? car promis avant de poster, j'ai cherché trés longtemps !!!
    Merci
  • Re: AttributeError: @@plone

    Envoyé par encolpe le 4 Octobre 2006 à 08:27
    C'est un problème récurrent de perte de contexte qui est censé être réglé dans la version 2.5.1
  • Re: AttributeError: @@plone

    Envoyé par davconvent le 4 Octobre 2006 à 08:52
    dans 2.5.1 je n'ai pas ce problème au niveau du browser, mais l'erreur apparaît toujours dans les logs..
    zarbi
  • Re: AttributeError: @@plone

    Envoyé par fcarlier le 4 Octobre 2006 à 10:14
    Mon site est sous Plone 2.5; Vous me conseillez de le passer en 2.5.1?? J'étais pas trop chaud!!

    Sinon, la perte de contexte me genere une erreur dans le log et surtout un ecran web avec l'erreur pour le user. Davconvent, tu dis que dans les log tu as encore le message,ok,mais aussi sur le site ?

    Merci de vos réponses !!
  • Re: AttributeError: @@plone

    Envoyé par fcarlier le 4 Octobre 2006 à 13:13
    Je viens de commencer la migration pour l'hiver !!!

    passage de Zope 2.9.3 -> Zope 2.9.5.
    Tout à l'air ok sauf ...
    Dans la ZMI, la racine type manage_main me donne :

    Traceback (innermost last):
    Module ZPublisher.Publish, line 115, in publish
    Module ZPublisher.mapply, line 88, in mapply
    Module ZPublisher.Publish, line 41, in call_object
    Module Shared.DC.Scripts.Bindings, line 311, in __call__
    Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    Module App.special_dtml, line 176, in _exec
    Module DocumentTemplate.DT_Let, line 76, in render
    Module DocumentTemplate.DT_Util, line 196, in eval
    - __traceback_info__: REQUEST
    Module , line 0, in ?
    NameError: name 'getDefaultSorting' is not defined

    alors j n'ai pas vraiment besoin de la zmi de la racine, puisque mon site Plone 2.5 transféré marche encore !!! mais bon, je n'aime pas cela !!!

    Je vais attendre un peu avant de passer de plone 2.5 -> plone 2.5.1 d'avoir corriger cette première erreur !

    Merci de vos futurs contrib !!!!
  • Re: AttributeError: @@plone

    Envoyé par fcarlier le 4 Octobre 2006 à 18:28
    Grace à Encolpe, trouver le problème de la deuxième erreur,
    pour zope 2.9.5, il faut utiliser le Product ExternalEditor de Plone 2.5.1 mais pas celui de Plone 2.5 !!

    Je transfere mon site sous Zope 2.9.5 puis je m'occupe de Plone 2.5.1 au lieu de 2.5 !! On verra si cela résoud le premier Traceback.

    Si vous avez des idées, je suis preneur !!!
  • Re: AttributeError: @@plone

    Envoyé par flebourdelles le 7 Août 2007 à 01:44
    J'ai un probleme similaire ... mais systématique :

     Zope Version

    (Zope 2.9.7-final, python 2.4.4, linux2)
    Python Version

    2.4.4 (#1, Aug 5 2007, 12:54:32) [GCC 4.1.2 20070302 (prerelease) (4.1.2-1mdv2007.1)]
    System Platform

    linux2
    SOFTWARE_HOME

    /opt/Plone-2.5.3/lib/python
    ZOPE_HOME

    /opt/Plone-2.5.3
    INSTANCE_HOME

    /opt/Plone-2.5.3/zeocluster/client1
    CLIENT_HOME

    /opt/Plone-2.5.3/zeocluster/client1/var
    Network Services

    ZServer.HTTPServer.zhttp_server (Port: 8080)
    Process Id

    4863 (-1259172960)
    Running For

    12 min 43 sec

    et voici le traceback de mon site corsica2007 :
    Site Error

    An error was encountered while publishing this resource.

    AttributeError
    Sorry, a site error occurred.

    Traceback (innermost last):

    * Module ZPublisher.Publish, line 196, in publish_module_standard
    * Module Products.PlacelessTranslationService.PatchStringIO, line 34, in new_publish
    * Module ZPublisher.Publish, line 146, in publish
    * Module Zope2.App.startup, line 222, in zpublisher_exception_hook
    * Module ZPublisher.Publish, line 115, in publish
    * Module ZPublisher.mapply, line 88, in mapply
    * Module ZPublisher.Publish, line 41, in call_object
    * Module Shared.DC.Scripts.Bindings, line 311, in __call__
    * Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
    * Module Products.CMFCore.FSPageTemplate, line 195, in _exec
    * Module Products.CacheSetup.patch_cmf, line 50, in FSPT_pt_render
    * Module Products.CacheSetup.patch_cmf, line 116, in PT_pt_render

    * Module TAL.TALInterpreter, line 238, in __call__
    * Module TAL.TALInterpreter, line 281, in interpret
    * Module TAL.TALInterpreter, line 749, in do_useMacro
    * Module TAL.TALInterpreter, line 281, in interpret
    * Module TAL.TALInterpreter, line 457, in do_optTag_tal
    * Module TAL.TALInterpreter, line 442, in do_optTag
    * Module TAL.TALInterpreter, line 437, in no_tag
    * Module TAL.TALInterpreter, line 281, in interpret
    * Module TAL.TALInterpreter, line 749, in do_useMacro
    * Module TAL.TALInterpreter, line 281, in interpret
    * Module TAL.TALInterpreter, line 511, in do_setGlobal_tal
    * Module Products.PageTemplates.TALES, line 221, in evaluate
    URL: file:CMFPlone/skins/plone_templates/global_defines.pt
    Line 3, Column 0
    Expression: standard:'context/@@plone'
    Names:

    {'container': ,
    'context': ,
    'default': ,
    'here': ,
    'loop': ,
    'modules': ,
    'nothing': None,
    'options': {'args': ()},
    'repeat': ,
    'request': ,
    'root': ,
    'template': ,
    'traverse_subpath': [],
    'user': }

    * Module Products.PageTemplates.Expressions, line 185, in __call__
    * Module Products.PageTemplates.Expressions, line 173, in _eval
    * Module Products.PageTemplates.Expressions, line 127, in _eval
    __traceback_info__: context
    * Module Products.PageTemplates.Expressions, line 286, in restrictedTraverse
    __traceback_info__: {'path': ['@@plone'], 'TraversalRequestNameStack': []}
    * Module Products.Archetypes.BaseObject, line 1140, in __bobo_traverse__

    AttributeError: @@plone (Also, the following error occurred while attempting to render the standard error message, please see the event log for full details: @@plone)
Rendu par Ploneboard